Zend Framework を Xampp にインストール時のエラー

Zned Framework の Skeleton をインストール時にPHPのVersionに関してのエラーが出てインストールができない。エラーメッセージは以下

 

Your requirements could not be resolved to an installable set of packages.
Problem 1
- zendframework/zendframework 2.5.1 requires php >=5.5 -> your PHP version (5.4.41-0+deb7u1) does not satisfy that requirement.

 

 

Zend Framework の要求する PHP CLI (コマンドライン) のVersionが、インストールされているPHP CLIのバージョンと違うって事なんだろうが、php_info() で見る限りZendの要求に合致しているが、php -v で見るとphp_info()よりも古いバージョンが表示される。Xamppのパッケージングの問題なのか良く分からないが、ひとまず以下の方法で解決できた。

 

1. composer.json を開く。

> vi composer.json

 

2. 以下のようにバージョンを変更し保存する。

// 変更前
"php": ">=5.5",
"zendframework/zendframework": "~2.5"
// 変更後
"php": ">=5.4",
"zendframework/zendframework": "~2.4"

3.  Composer.lock を開き、5.5 で検索して、5.4 に書き換る。2か所ある。

4.  保存する。

5. composer.phar を実行

> php composer.phar install
Bookmark the permalink.

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です